SpamAssassin güncelleme hatası ve çözümü

SpamAssassin , gelen e-postanın potansiyel olarak SPAM olup olmadığını belirlemek için bir dizi kural kullanan popüler bir SPAM filtreleme programıdır.

Bu hafta Truva Linux web sunucusunda güncelleme yaparken SpamAssassin paketinin güncelenemediğini farkettim.

çıktı
Setting up spamassassin (3.4.2-0ubuntu0.14.04.1) ...
dpkg: error processing package spamassassin (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of sa-compile:
sa-compile depends on spamassassin (>= 3.3.2-8); however:
Package spamassassin is not configured yet.

dpkg: error processing package sa-compile (--configure):
dependency problems - leaving unconfigured
Processing triggers for ureadahead (0.100.0-16) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
spamassassin
sa-compile
E: Sub-process /usr/bin/dpkg returned an error code (1)

biraz gogıllayınca  çözümü buldum.

SpamAssassin sisteme kurulurken eklenen sistem kullanıcısına atanan kabuk "/bin/false" olarak ayarlanmış

bunu "/bin/sh" olarak set edilince problem ortadan kalktı.
# apt-get install spamassassin
Reading package lists... Done
Building dependency tree
Reading state information... Done
spamassassin is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up spamassassin (3.4.2-0ubuntu0.14.04.1) ...
SpamAssassin Mail Filter Daemon: disabled, see /etc/default/spamassassin
Setting up sa-compile (3.4.2-0ubuntu0.14.04.1) ...
Running sa-compile (may take a long time)
SpamAssassin Mail Filter Daemon: disabled, see /etc/default/spamassassin

Geriye sadece SpamAssassini yapılandırmak kaldı :)

Çözüm kaynağı. https://rattis.net/2015/02/27/apt-get-upgrade-spamassassin-error/

 

 

 
caylakpenguen
caylakpenguen

Truva Linux takımıyla 2006'da tanışan "Çaylak Penguen" -BASH- betiklerine bayılır. Truva'nıñ çekirdek derleme işleri ile çalışan cd tasarımıyla uğraşmaktadır.

2 yorum:

  1. Teşekkür ediyorum hatayı çözüme kavuşturduk :)

    YanıtlayınSil
  2. caylakpenguen4 Şubat 2019 13:54

    Rica ederim.
    Faydalı olmasına sevindim.

    YanıtlayınSil